Merchant dashboard
Incident Report for Klasha Status
Resolved
This incident has been resolved.
Posted Nov 11, 2024 - 14:40 CET
Investigating
Hi all, our merchant dashboard is currently undergoing maintenance and will be back up shortly
Posted Nov 11, 2024 - 13:52 CET