Payment Link Maintenance
Incident Report for Klasha Status
Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 19:41 CET
Update
We are continuing to investigate this issue.
Posted Nov 21, 2024 - 16:42 CET
Investigating
Hi all, our payment link is currently undergoing maintenance and will be back up shortly.
Posted Nov 21, 2024 - 16:41 CET
This incident affected: Payment Link.