NIBSS Downtime

Incident Report for Klasha Status

Resolved

This incident has been resolved.
Posted Aug 16, 2024 - 13:47 CET

Investigating

Dear All,

Please note that we are having a downtime on NIBSS(NGN) and would affect bank transfer collection and payout.

However, we will continue to provide updates.

Affected Services: Bank transfer transactions (B2B and B2C)
Affected Markets: Nigeria
Posted Aug 13, 2024 - 18:32 CET