Issue with NIBSS

Incident Report for Klasha Status

Resolved

Dear All,

Please be informed the ongoing issue with NGN Bank transfer transactions (NIBSS) which impacted the processing of certain transactions has been resolved.

However, we will continue to monitor to ensure stability.

Affected Services: Bank transfer transactions (B2B and B2C)
Affected Markets: Nigeria
Posted Jun 17, 2024 - 19:00 CET